Ad

2018/11/15

在 Mojave 上執行 Snow Leopard

不經不覺 macOS X 已來到了第 14 個版本,名字叫 macOS Mojave,而在 macOS 歷史裡,macOS 10.6 Snow Leopard 可說是一個分水嶺,不少舊的應用軟件如果不作更新,往往未能過渡至 macOS 10.7 Lion 或以後的系統。

我在 Mactivity 日常使用一個叫 Quicken 2007 的軟件做會計記賬,它只可在 Snow Leopard 上執行,而新版的 Quicken 又不太合我心意,於是我仍保留一部很舊的 MacBook Pro 專門用作 Snow Leopard / Quicken 之用,如果這台舊 Mac 壞掉,新機又不能執行 Snow Leopard,那怎算好?如果你手上仍有一些舊軟件只能在 Snow Leopard 上執行,又保留了 Snow Leopard 的光碟,可參考今次介紹的方法,用虛擬方式來解決。

【在虛擬環境下執行 Snow Leopard 軟件,可能涉及軟件授權問題,如對軟件授權有疑問,請參考軟件授權文件。】

先到 VirtualBox 網站下載 OS X hosts
安裝及執行 VirtualBox
指定建立 Mac OS X 10.6 Snow Leopard (32-bit)
選擇記憶體大小
建立一個 20GB 的虛擬磁碟
選擇 VDI 格式
選擇動態的硬碟容量
給它一個名稱
按 Start 開始安裝
提供 Snow Leopard 光碟映像檔位置(可用光碟版產生)
一堆外星語言
看到熟悉的安裝畫面了 
用磁碟工具程式把虛擬硬碟格式化 
安裝到 20GB 的虛擬硬碟
安裝進行中......
再辨認一次鍵盤
成功安裝 macOS X 10.6 Snow Leopard 了
也成功安裝了舊版的 Quicken 2007

2018/11/09

如何從 App Store 下載已消失的 macOS

Apple 一直鼓勵 Mac 電腦用家升級到最新版的 macOS,近幾年更把 macOS 變為免費下載,令更多用家可以毫無顧慮享受新 macOS 帶來的新功能。 

大家可能會發現,在新版 macOS 推出後,Apple 就會把舊版 macOS 從 Mac App Store 中抽起,例如在最新 macOS Mojave 推出後,舊版的 macOS High Sierra 就會被消失,其它更舊的 macOS 例如 Sierra 或 El Capitan 等,也在新 macOS 推出後就被消失。

假如你正在使用較舊的 macOS,錯過了上幾代的更新,最近又剛好購買了新的軟體(例如 Adobe CC 2018)或硬體(iPhone XS),你可能會發現正在使用的 macOS 實在太舊,必需稍稍升級 macOS 才能順利操作,卻又發現自己的電腦並不兼容 macOS Mojave,是否就沒法退一步安裝 High Sierra、Sierra、El Capitan 等操作系統呢? 

其實 Apple 在 Mac App Store 仍然保留有 High Sierra、Sierra、El Capitan 這些舊版 macOS,只是把它隱藏起來,在 Apple 的支援網頁中有提供 Mac App Store 相關連結,有需要的朋友可自行下載。

macOS High Sierra 支援網頁









2018/11/06

Mac App Store 的使用語言

想在 Mac 上想改變使用語言十分簡單,只需到「系統偏好設定>語言與地區」,在偏好語言加入想要的語言,並把它拖到最高,重新開機就可以。 
最近把偏好語言由英文改為繁體中文後,卻發現 App Store 的語言仍然停留在英文,雙語並行,十分混亂,原來找解決方法非常簡單,只需按一下帳戶,選擇檢視資料,輸入 Apple ID 及密碼後,你就會發現 Mac App Store 的語言會跟 Mac 的系統語言回復一致。