Ad

凡經以上廣告連結購買任何 Mac 主機,憑單到 Mactivity 可免費獲贈《打開 Mac 新世界》工具書一本及九折購買 AppleCare 一份。

2011/07/11

OS X Lion 升級準備



差不多兩年前,寫過「Snow Leopard 升級困惑」,提醒大家在幾個 Snow Leopard 版本之間應如何選擇。今次的 Lion 升級則簡單得多,因為你再不需要在不同版本之間決擇,它只有一個版本,也只有一個購買方式。

如果你已擁有配備 Intel Core 2 Duo、Core i3、Core i5、Core i7 或 Xeon 處理器的 Mac(Intel Core Duo 及 Core Solo 將不支援 Lion),而又已經安裝了 Snow Leopard 10.6.8 的話(未有安裝 Snow Leopard 的朋友可聯絡 Mactivity 升級),在 Lion 推出當日,你就可以足不出戶、直接在 Mac App Store 購買、下載及安裝 Lion。因為 Mac App Store 需要先登記才能使用(否則怎透過信用咭扣錢),你可以沿用 iPhone 或 iPad 上的 iTunes 賬號,也可以從新登記一個新的。

但我想提醒大家,尤其是倚靠 Mac 作「搵食機」的朋友,最好還是多做一點準備功夫。

首先,從 Snow Leopard 跳到 Lion 是一個很大很大的升級,宜先看一遍「應否更新」。

接著,可以重溫五年多前、在剛推出 Intel Mac 時寫的「買機疑惑:PowerPC vs Intel」,認真懷舊。

簡單來說,Snow Leopard 仍然可以安裝 Rosetta 模擬器,讓 Intel Mac 繼續執行以往為 PowerPC Mac 而編寫的軟件。五年多過去了,當年的 Microsoft Office 2004、Adobe CS2 都演化到 Microsoft Office 2011 及 Adobe CS5.5 了。Apple 覺得是時候完全捨棄 PowerPC 這個包袱,正式全身投入 Intel 的世紀,由 Lion 開始,將不會再支援 Rosetta 模擬器了。

換句話說,如果你的電腦仍安裝有設計給 PowerPC Mac 的軟件,而該軟件又沒有更新成 Intel Mac 兼容的話,在 Lion 之下,該軟件將會不能執行!


你可以到「應用程式」>「工具程式」之下,打開「系統描述(System Profiler)」,在左邊點選「軟體」>「應用程式」,你會看到所有內置的應用程式,在「種類」項目下可以分為:
  • Intel 代表只支援 Intel Mac,在 Lion 下可順利執行。
  • Universal 代表同時支援 Intel Mac 及 PowerPC Mac,在 Lion 下也可順利執行。
  • PowerPC 代表只支援 PowerPC Mac,在 Lion 下因為沒有了 Rosetta 模擬器,所以 Intel Mac 再不能「扮作」PowerPC Mac。換言之,這個軟件將不能在 Lion 下執行。
例如我日常使用的 MacBook 上,就有一個叫 Quicken 的會計軟件,已知道不能在 Lion 下執行;而公司的一台 HP 打印機,因為日子久遠,好像也只有 PowerPC 的驅動程式。你的電腦上,又有多少 PowerPC 應用程式呢?

我不會第一時間把自己的「搵食機」升級到 Lion,但 Mactivity 不知道甚麼原因,實在有太多 Mac 了,相信我可以輕易的找到一台 Mac 做白老鼠,玩玩這隻獅子。

10 則留言:

Chris Chan 說...

Hello johnny,

I am a user of parallel desktop 6. And do you know if there is any incompatible issues with Lion OS?
I just afraid the upgrade would cause parallel not working.

Thank you

Johnny Chan 說...

As Parallels Desktop 6 is still the current version of Parallels, I believe Parallels should release a patch to maintain the compatibility with Lion.

匿名 說...

According to the following "App Compatibility Table", Parallels 6 should be compatible...(but my Parallels 5 isn't :<)
http://roaringapps.com/apps:table

Nicole J.S.J 說...

您好, 我想請問一下, 升級過後, 那些之前安裝的其他軟體會消失嗎?像是office 2011之類的還可以順利使用嗎?謝謝您的幫忙

匿名 說...

為何升級了lion, 但office 2010既word開不倒舊files....??

wah lung 說...

你好,剛搵關於MAC OS就見到你個blog,我想問我現在部mac book pro係MAC OS X 10.5.8, 我應該升去OS X LION還是Snow Leopard,我還未搞得懂這分別,因為我正打算試寫IPHONE App, 但佢話要我升到10.6.6先得。請問我應該點做?唔該晒。

Johnny Chan 說...

Office 2010 是 Windows 的嗎?我在 Lion 上打開 Office 2011 沒有問題。
Wah Lung,你要先升級上 Mac OS X 10.6.8,價錢是 $238(Mactivity 有售),就可以寫 App 了。如果日後想再升上 Mac OS X 10.7,就要在 Mac OS X 10.6.8 中自行下載及購買。

Oranger B 說...

Hi Johnny,

How about Parallel desktop 3?? I know it's been released for quite some times already.

Do you know if this is still compatible with Lion OS?

Thanks

Johnny Chan 說...

Only Parallels 6 is compatible with Lion.

CK 說...

Lion連isync都殺埋! 而家冇辦法同nokia同步,Apple真係做得好絕!